
Tutorial para iniciantes: 
software ENVI-met 

versão 3.1 

Atualizado em outubro de 2014 

PS: as figuras do tutorial são meramente ilustrativas e 

certamente são valores tomados como exemplo 

Contato: friquemendes@usp.br 



Instalação: http://www.envi-met.com/ 

Uma senha será requerida e enviada ao email do usuário  



E será instalado... 

5. Sair 

1. Editor de área (.in) 

2. Editor de configuração (.cf) 

3. Processador de dados 

4. Visualizador de mapas (Leonardo) 

PS: caso alguns usuários encontrem problemas na visualização de mapas (4° item 
– Leonardo), subitem ͞Settings 2D ,͟ basta abrir o ENVI-met no modo de 
compatibilidade. 



1. Escolher área e salvar imagem no formato BITMAP, 24 bits, com melhor resolução 
possível e, de preferência, sem legendas, pois pode atrapalhar a modelagem.  
 
PS: 1: a versão 3.1 não faz simulações para áreas inclinadas; 
      2: o raster (imagem) servirá apenas para a digitalização do usuário, sem 
importância para o  programa; o que interessa são as informações que serão colocadas 
por cima da imagem. 



2. Abrir o Editor de área do ENVI-met (1° item) e 
clicar em Select a background bitmap to digitalize on 
screen e carregar a imagem .bmp 



3. Ajustar a imagem (passos a, b e c): 
 
a. Se houve rotação no norte verdadeiro, colocar o grau em model rotation out of 

grid north (positivo ou negativo). Em seguida, fazer os ajustes  do Location on 
Earth, conforme a cidade da área de estudo. Se o local não estiver cadastrado no 
software, inserir manualmente as coordenadas em graus decimais e a zona de 
referência. Apply Changes; 



b. Para correção da distorção da imagem, encontrar a taxa de proporção na imagem .bmp. 
Ex: 469/388 = 1.208763; então, multiplico por 40 (grid padrão inicial): 
x-grids = 40 e y-grids = 48.35 
 
Devido ao número decimal 48.35, é preciso encontrar o ͞fator de arredondamento decimal 
(fad) ,͟ visto que a quantidade de grids é número inteiro: 
fad = 1.2 -> x-grids = 48 e y-grids = 58 
 
Para aumentar detalhes da digitalização, pode ser aplicado o ͞fator de auŵeŶto͟: 
48 x 58 equivale à 96 x 116 (fator de aumento = 2). Apply Changes; 
 



c. Ajuste do tamanho de cada grid: size of grid cell in meter: distância no Google Earth 
dividido pelo grid; 
 
Ex: dy -> 406 m / 116 grids = 3.5 m cada grid 
      dx -> 336 m / 96 grids = 3.5 m cada grid 
Como foi feita a taxa de proporção, dx = dy. Se não for, ou está errado o valor da distância 
(m) ou foi por causa de arredondamentos (grids). Precisa ser refeito. Apply Changes. 



Para salvar o arquivo: File -> Save as... 
PS: vale lembrar que se o arquivo for fechado e reaberto, é preciso carregar a imagem 
.bmp novamente. 



4. Iniciar a digitalização, preenchendo todos os grids com alguma informação: 
- edição de construções, vegetação e solo, respectivamente. 
 
a. Construções: ver a altura, digitar o valor e marcar na imagem;  
-> para remover, digitar 0 e passar por cima; 



b. Vegetação: escolher o tipo de árvore e marcar na imagem (pressionando shift); 
-> para remover, selecionar <remove> e passar por cima; 



c. Solo: marcar a camada de edição edit soils; depois, ver qual tipo de solo mais 
ocorre na imagem (geralmente é asfalto para cidades), selecioná-lo e clicar em 
apply to all grids; por fim, digitalizar as exceções (água, solo arenoso, concreto, 
etc.), passando por cima do solo anterior; 
-> para remover, selecionar 0 <default useald soil> e passar por cima. 



PS: consultar informações adicionadas em cada grid , por meio do cursor position: 
-> no exemplo abaixo, tem-se que o ponto exato no grid corresponde: 
x,y = 39,95 ou 136.5 m x 332.5 m (valores multiplicados pelo dx = dy = 3.5 m) 
Está sem altura de edificação (z=0); 
Possui árvore de 10 m de copa muito densa; 
Tipo de solo é o asfalto. 



Opcionalmente, pode ser adicionado receptores no modelo, de forma que esses 
coletem dados simulados. Ex: receptor ͞15 .͟ 



5. Ajustar o dz (em File -> Change Settings): (z-Grids x dz) deve ser pelo menos o dobro da 
altura do maior edifício (verificação ao término da edição). Ex: maior edifício com 30 m, 
deixar z-Grids = 20 (máximo = 30, que é o tamanho da grid de simulação) e alterar dz para 
4.0 (2 x 30 ≤ 20 x 4). Assim, z máx. do modelo = 80 m. Apply changes.  



PS: conferir análise do modelo: 
 
-> (i) análise geométrica e (ii) distância mínima entre edificações e a borda do modelo: 
ambos precisam estar ok (em verde) – Menu Tools -> Model Analyser 

Se não estiverem verdes: 
(i) Aumentar valor de dz (item 5) 
(ii) Aumentar área de borda (próximo passo) 



Para aumentar área de borda, alterar o Nr of nesting grids, até o Model Analyser ficar 
verde: 



Ao final da edição da área, salvar o arquivo (File -> Save as...) com a extensão .in e 
adicioná-lo na pasta input do ENVI-met (por padrão, C:\ENVImet31\input) 
 



6. Fazer o arquivo de configuração (.cf) -> 2° item do 
ENVI-met (vide configurações do Bruse em: 
http://www.envi-met.com/htmlhelp/hs60.htm) 

DICAS: 

 
- Evitar começar simulação ao meio-dia, optando pelo 
período noturno ou nascer do sol; (condições de 
atmosfera neutra); 
- Ter pelo menos 6 horas de simulação para não ter 
influência da inicialização; 
- A temperatura usada é a potencial 
(http://www.mares.io.usp.br/iof201/c4.html), na qual 
a temperatura in situ pode ser convertida para a 
potencial: 
http://www.shodor.org/os411/courses/_master/tools
/calculators/pottemp/pt1calc.html 



6.1. http://weather.uwyo.edu/upperair/sounding.html -> site para encontrar a 
temperatura potencial a 2500 m, onde 00Z corresponde às 21h00 do dia anterior e 12Z, 
9h00 do dia mostrado (horário de Brasília –> GMT-3). Ver colunas HGHT (m) e TEMP (C) e 
fazer regressão linear para 2500 m.  



Fazer o gráfico da pressão (PRES hPa) em função da altitude (HGHT m), numa regressão 
exponencial. 

(Correção por meio do Shodor, na qual a 
pressão em mb equivale a hPa; no caso, 

temperatura potencial = 311.76) 

E, posteriormente, obter a temperatura 
potencial corrigida, por meio do Shodor, ao 
entrar com os dados de temperatura e 
pressão: 



6.2. http://weather.uwyo.edu/upperair/sounding.html -> site para encontrar a umidade 
específica a 2500 m, onde 00Z corresponde às 21h00 do dia anterior e 12Z, 9h00 do dia 
mostrado (horário de Brasília –> GMT-3). Ver colunas HGHT (m) e MIXR (g/kg) e fazer 
regressão exponencial para 2500 m.  



Dica: por meio da Calculadora Vaisala, é possível encontrar umidade relativa do ar, uma 
vez conhecida a temperatura do ar e do ponto de orvalho: 
http://br.vaisala.com/humiditycalculator/vaisala_humidity_calculator.html?lang=en 

6.3. http://gis.ncdc.noaa.gov/map/viewer/#app=cdo -> site para variáveis climáticas: 
Time-Related Maps -> All Observation Times -> Select by rectangle -> escolher a estação 
meteorológica -> Get selected data -> Access data -> escolher o período -> continue -> 
concordar com o Inventory Review e pôr o email. Será enviado um link com dados de 
direção e velocidade do vento (DIR e SPD), temperatura do ar (TEMP), temperatura do 
ponto de orvalho (DEWP), etc.  



Menu -> File -> New Configuration. De modo organizacional, aconselha-se pôr o mesmo 
nome para os arquivos .in e .cf.  
 
 
- Input file Model Area -> C:\ENVImet31\input\<nome>.in 
- Output Directory -> C:\ENVImet31\output\ (criada automaticamente pelo ENVI-met) 
- Start Simulation at Day -> data que será inicializado o modelo 
- Start Simulation at Time -> horário que será inicializado o modelo; em virtude da 
disponibilidade de dados da Universidade de Wyoming (sondagem atmosférica), em 
conjunto com as recomendações do desenvolvedor Bruse (2009), iniciar às 21:00:00 
(para locais com horário de Brasília). 
- Save Model State each -> a cada quanto tempo será salvo o modelo 
- Database Plants -> C:\ENVImet31\sys.basedata\Plants.dat 
É possível adicionar mais informações de input por meio do Menu -> Add Section 
 

 
PS: respeitar as unidades exigidas pelo software! 
Quanto mais informações complementares for informada (Add Section), mais realista 
tenderá a ser a simulação. 

Preparação do arquivo .cf 



Fonte: Série de Dados Climatológicos do Campus Luiz de Queiroz de Piracicaba, SP, disponível em 
<http://www.leb.esalq.usp.br/postoaut.html>, considerando velocidade média do vento e direção 
predominante ao longo do dia. 

Exemplo de arquivo .cf: 

No exemplo, dados de input referem-se ao dia 23/12/2011 e os outputs corresponderão 
aos dias 23 (à noite, que serão desconsiderados), 24 e 25/12/2011 (i.e., 48h simuladas); 
PS: Limitações do vento: (i) velocidade constante no processamento (Rosseti, 2013); (ii) 
ventos inferiores a 0,8 m/s causam instabilidade no modelo (Francisco, 2012). 



Localização da área na Terra: adicionar essa informação no arquivo .in e não 
no arquivo .cf; vide <http://www.envi-met.com/htmlhelp/hs40.htm>  



Dados de solo para três camadas; 



Intervalo de tempo para atualizar informações sobre as variáveis e 
salvar (em segundos); não utilizar intervalos maiores que o padrão; 



Intervalo de tempo para o cálculo da posição do sol; valor 
máximo de 10 s; 



Turbulência: modelos de fechamento para equações de 
estado para 1D (ABL) e 3D; 



Receptores: adicionar a posição do receptor no grid e o tempo que deseja 
salvar os resultados simulados. Servem para comparar medido com 
simulado, na qual pode-se ter valores de variáveis climáticas no exato ponto; 



Características dos edifícios, como temperatura interna, 
transmissão térmica e albedo; 



Condições de insolação para o modelo 1D: minimizar o efeito do 
entorno que não está modelado; adicionar essa informação no arquivo 
.in e não no .cf; vide <http://www.envi-met.com/htmlhelp/hs40.htm> 



Dados para o PMV, índice de conforto proposto por Fanger (1972); 



Definições para plantas: 
- Deardorff (estimado) ou Jacobs (fisiologia) 
- Concentração de CO2; 



Define o tipo de fronteira lateral para: 
- T e q (temperatura e umidade)  
- TKE e ε (variáveis de turbulência – energia cinética de 
turbulência e taxa de dissipação) 



Dados de input mais complexo (Bruse, 2009); referem-se aos tipos 
de poluentes emitidos (gás e/ou particulado); 



Você pode preparar seu próprio banco de dados para plantas e 
partículas: basta indicar o diretório; 



Fração de nuvens baixas, médias e altas no céu (em oitavas de céu); 



Fator de ajuste da radiação; o valor varia entre 0.5 e 1.5 e deverá 
ser ajustado posteriormente. 

# Ao final, salvar o arquivo .cf na pasta de input: 

File -> Save as -> C:\ENVImet31\input\<nome>.in 



7. Ajustando a radiação e fazendo a simulação:  
 
 
Em alguns casos, para o processamento de dados e visualização de resultados, é 
necessário abrir o software no modo de compatibilidade. No Windows 8, segue o 
procedimento: 
Botão direito sobre o executável -> propriedades -> compatibilidade -> executar solução 
de problemas de compatibilidade -> tentar configurações recomendadas -> testar o 
programa -> sim.  
 
 
Clicar no 3° item do ENVI-met e abrir grid adequada (não esquecer que o Nr of  nesting 
grids também conta). 
No exemplo, 96 x 116 x 20 com 5 nesting grids utilizar 180 x 180 x 30. 
 
 
PS: quanto maior o grid de simulação, maior será o tempo de processamento do modelo.  
A estrutura de programação atual não permite processamento em paralelo de forma 
eficiente (BRANDÃO, 2009). 



Ao lado direito, substituir [PROJECTS] para [HOME]. Então, em Load model configuration,  
abrir pasta input e carregar <nome>.cf 



AJUSTE DA RADIAÇÃO: 
 
Através do Preview, verificar qual fator de ajuste será utilizado. 
 
PS: posteriormente, é necessário acrescentá-lo ao arquivo .cf, visto que o Preview tem 
apenas função visualizadora e, logo, não terá influência sobre a simulação. 



Ajuste da radiação:  
 
-> Correspondente ao 1° dia da simulação (23/12/2011). No exemplo, fez-se o gráfico da 
radiação global e verificou-se 12h00 = 1031.31 W/m² 

Fonte: Série de Dados Climatológicos do Campus Luiz de Queiroz de Piracicaba, SP, disponível em 
<http://www.leb.esalq.usp.br/postoaut.html> 



Dessa forma, diminuiu-se o fator de ajuste de 1.00 para 0.93, tornando o balanço de 
radiação mais fiel com a realidade 



Reabrir o arquivo .cf e 
adicionar o ajuste da radiação 



8. Testar o modelo 
 
Carregar novamente o .cf (com o ajuste da radiação) -> clicar em Test configuration 
<nome>.cf  



O teste normalmente não demora mais que 1 minuto (Check done) 
Se houver erros verificados pelo teste, corrigi-los; caso contrário, OK 



É possível selecionar as variáveis desejadas do Output: quanto mais variáveis, mais 
tempo demorará 



9. Iniciar simulação: Run model <nome>.cf  
 
PS: é comum simulações demorarem de 1 a 5 dias, mesmo em bons processadores e 
boa memória RAM 



10. Ao término, resultados disponíveis em  
C:\ENVImet31\output\  
Visualização: 4° item do ENVI-met (Leonardo)  
 
Menu Tools -> Data Navigator ( ou comando Ctrl+A) 

(Selecionar arquivo .edi) 



1. File -> salvar e exportar mapas 

2. Tools -> exportar metadados em .dat 

3. Animation -> animação de partículas; permite exportar vídeo em .avi 

4. <command> -> edição de título, subtítulo, eixos x e y, etc 

5. Position -> mostra o local exato do cursor em grid x,y e real (metros) 

6. Data -> mostra o valor exato do dado, baseado na variável de referência (no caso, 

velocidade do vento) 

7. Settings 2D -> caixa de comando do design do mapa, conforme segue: 

PS: como exemplo, será mostrada a seguir uma área de teste já 

simulada e não a área previamente modelada 



a. Special - Layer -> possível deixar edificações em preto 
b. Vector / Particle -> adicionar trajetória de partículas 
c. Text and Layout -> editar título, subtítulo, etiquetas 

x,y, eixos secundários e idioma 
d. Data key -> intervalos da escala, casas decimais e 

paleta de cores 
e. Arrows -> ajuste do norte (EX: mapa original) 



a. Special - Layer -> edificações em preto 
 
-> ENVI-met defaults -> selecionar apenas ͞buildings͟ -> Show Special-Layer (é preciso 

͞arrastar͟ a janela Settings 2D para cima para aparecer a opção) -> Apply 



b. Vector / Particle -> trajetória de partículas 
 
-> alterar valor de Length scale vectors, ticar Filled vector arrows e Draw random vectors, 

alterar 10000 para 1000 e ticar Show Vector-Layer in map 



c. Text and Layout -> editar título, subtítulo, etiquetas x,y, eixos secundários e idioma 
 
-> alterar características desejadas, como idioma (vide escala) e eixos secundários (vide 

mapa) 



d. Data key -> intervalos da escala, casas decimais e paleta de cores 
 
-> para modificar manualmente a escala, desmarcar Optimise key to existing data range 

e modificar First value e Step size; para a paleta de cores, Edit color sets 



e. Arrows -> ajuste do norte 
 
-> Se houver rotação do norte, é necessário acrescentar a informação 



É possível exportar metadados (arquivo .dat), que pode ser aberto pelo Quantum 
Gis, Bloco de Notas ou Excel, com matriz x,y,valor (o ͞espaço͟ é o delimitador de 
caracteres).  
Para converter formato no Qgis (para .tif, por exemplo) ->  Raster -> Conversão -> 
Converter formato.  Após, a imagem pode ser georreferenciada e sobreposta em 
imagem aérea. 
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